SAシリーズトップ

  • 最近の使い方
    最近は5400rpm の40G HDD に換装して,全領域をDebian Etch にしています.
    これに大容量バッテリとW05K で輝度を落としてやると6~8時間持つ感じです. 電池がこれだけ持つとすごく気が楽です.:-)
    出先にAC なんかがあるかどうかわからない時などはSA1F の出番となっています.
    その他,手前のタッチパッドはケーブル抜いて無効にしています.

スペック

OS:Microsoft® Windows XP Home Edition SP2
AMD®Geode™ -LX800
メモリ:512MB
ハードディスク:40GB(SA1F00A)
:80GB(SA1F00B)
無線LAN:IEEE802.11b/g準拠
Bluetooh  Ver,2.0+EDR Class-1
光沢パネル付7型ワイド TFTカラー液晶

質量:約960g(バッテリー装着時)

SA1F00A/SA1F00B - 製品情報 - プロのモバイルノート 工人舎ダイレクト

インプレッション

サイズ/重量

NotePC としてはかなり小さい.鞄にひょいと入れて持っていける感じ.Vaio c1 っぽい
しかし,手に持って操作しようとすると微妙に大きい.Zaurus の様に両手で持って親指でKey 入力は辛い.液晶を回してポインティングデバイスだけの操作なら結構快適.
寝転がって操作していると,1kg が思ったより応える.読書用端末にはこの辺がネックか.

比較写真.上から,SL-C3000/SA1F/VAIO C1/Interlink MP-XV631

ACアダプタ

アダプタ本体は小さめだけどInterlink MP-XV631 の物より少し大きい,OUT は19V/2.63A 結構余裕がありそう.
ネガネコードは240V対応のためか結構太い.100V 環境でAC アダプタを持ち運んでで利用する分には細いめがねコードに変えたほうが楽かも.但し自己責任で.火が出ても知りません:P

液晶

画面

つるつる. ポインティングデバイスの操作で指紋が大量に取得できます.

解像度

800x480 だが,仮想的に1,024×600 に出来る.
800x480 でも意外と普通に使える.文章を打ったり画像を見るときはこのモード.ブラウザ等でWeb 閲覧時は1,024×600 という感じで使っている.
解像度切り替えもショートカット一発(Fn+ESC)で切り替えが効き,一瞬で解像度が変わるので使いやすい.
1,024x600 のモードは眠い感じになる.ぱっと見は良いが,長時間利用すると目が疲れる.
1,024x768 も使える様です.この場合,Fn+ESC で1,024x768 -> 1,024x600 -> 800x480 と3段階の切り替えになるようです.1,024x768 は流石に文字を読むのもつらいです….設定方法は,Windows の画面のプロパティで変更するだけです.

音量調整ダイヤル

Victor のInterlink にも同じ様なものがついているのだけれど,これは音量を変更すると画面上にボリュームが表示されるので使いやすかった.
こいつは見た目音量が判らないので少し不便.特に通常状態と液晶のみのビュー状態では本体が180度回転するので代償が逆になり紛らわしい.

CF スロット

TypeI なのだけれど,入り口はTypeII の高さがある.中にTypeII 避けっぽい出っ張りが邪魔をして入らない状態. この出っ張りを削ればTypeII も使えそうな感じ.
MicroDrive? を利用しているのでTypeII が使えると凄く嬉しい.

MICRODRIVE を押し込んでみると入って認識した.しかしMICRODRIVE に少し傷が付いた.とりあえずは使えるがやはり出っぱりは削らないとまずそう. そうそう,Eject の機能は無いのでMICRODRIVE の様にとっかかりの無いCard を差し込むときには引っ張り出せるようセロテープ等でベロを作っておいた方が良い.取り出すのに苦労する羽目に.

※WinXP でMicroDrive? を挿入すると,マウスカーソルが死ぬことがままあります.再起動で復帰. 電源周りかも.

SD スロット

半分しか刺さらないようになっている.半分はみ出した状態.刺したまま持ち運びは怖くて出来ないな.

USB

右側に1つ.左側にもカバーの中に1つあります.

Keybord

うーん.配列が独自なのは慣れていくとして,キーボードの質がかなり悪い. 入力していると凄くストレスがたまる.取りこぼしが多いので,syntax 間違えまくる. KeyClick? 音の出るアプリを探してみよう.
#ELECOM TK-U77MPBK(SN000999)より打ちづらい.

後,日本語変換のための漢字key がFn+1 とかなり押し辛い.Ctl+Space とかに出来るかな?

丁度良いsoft 見つけた.

皿M1.4x2 のネジを購入.
主なKey に入れた.大分改善されたと思う. Fn 等の小さなkey には今のところ入れていない.

購入したのは,秋葉原ラジオストアー内ストア・ミズタニ 100個入り\275-

キーが外れ易くもなった. 叩いてるときは良いけど,左側から何かに引っかけると外れやすく.#左側が浮いてる感じなので左からが外れやすい.

ポインティングデバイス

2系統のポインティングデバイスが実装されている.
キーボード手前のタッチパッドと,液晶両サイドのポインティングデバイス.
タッチパッドはきちんとマシンを置いて利用するときに使いやすいのだけど,パッドが狭いのでデフォルトでは移動量が小さい.クリックのkey も小さすぎて押し辛い.これはBT mouse を買えってことか.
液晶両サイドのポインティングデバイスは,左にカーソル移動,右に左右クリックがある.意外と使いやすいが,クリック時に間違えて上のスクロールキーを押してしまうことがある.これは馴れか.慣れてきた.

BIOS

起動時にF2 でBIOS 設定画面へ.
起動デバイスとして,PIX やUSB も選択できる.
デフォルトの起動順位は,HDD/USB FDD/USB HDD/USB CD の順.

無線LAN

11b/g 対応.内部ではUSB として認識している感じ.
電波強度は普通か少し弱いかも.
Defoult では起動時にoff になっているが,BIOS で設定することにより起動時よりOn にすることも可能.

工人舎謹製Linux 無線LAN Driver(動かず…)

工人舎のweb にlinux 用のdriver が有るよと教えて貰い,早速見てきました.
kernel 2.6.x 用と書かれたドライバが各種有ります.

先ずは一番使いたい無線LAN から

持ってきて,

% wget http://www.kohjinsha.com/support/driver/unsupport/w89c35-wpa37_Linux26.tar.gz

展開して,

% tar tvzf w89c35-wpa37_Linux26.tar.gz
drwxrwxrwx root/0            0 2007-01-29 19:15:28 w89c35-wpa37_Linux26/
-rw-rw-rw- root/0      4452440 2006-10-23 11:52:44 w89c35-wpa37_Linux26/w35und.ko
% tar xzf w89c35-wpa37_Linux26.tar.gz
% cd w89c35-wpa37_Linux26

読み込み.

% insmod ./w35und.ko
insmod: error inserting './w89c35-wpa37_Linux26/w35und.ko': -1 Invalid module format
%  dmesg |tail -1

w35und: disagrees about version of symbol struct_module Verion 違い?

% strings w35und.ko | grep 2.6
vermagic=2.6.11-1.1369_FC4 686 REGPARM 4KSTACKS gcc-4.0

どうやらこのドライバはFEdoraCore4 用の様です. bvi(vi チックなバイナリエディタ) で,該当場所をuname -a の結果に書き換えてみたけど変わらず…
今更FedoraCore4 なんて使いたくないですよ(;;
source 出してくんないかな….

Linux で無線Lan

markyさんの紹介で以下のページの方法を使って内蔵無線Lan がlinux でも利用できるようになりました.
無線使えないと不便なので,小さめのUSB 無線Lan デバイスかって着て無理やり内蔵できないかなとか考えてたとこでした.

※環境はDebian Etch kernel 2.6.18-5-686 ですが、他の環境でもドライバのパス以外同様の手順でいけると思います。
刺さりまくりです。OS 巻き込んでよくフリーズします。電源断しか選択肢がなさそうです。切り分けが出来てないのでびくびくしながら使ってます。

http://www.slacky.eu/forum/viewtopic.php?p=160507&sid=f8e7d16e251fb905182fa1bcd69f43ee を参考に, http://www.conitech.it/conitech/ita/risorse.asp?cod=CN402USB からc35_linux_source_hal_142_o.zip を貰って来ます.

展開して,2つのsource を1行ずつ書き換えてmake. 出来上がった.ko をドライバディレクトリにcp してドライバ読み込みでwlan0 が現れました.

debian% unzip c35_linux_source_hal_142_o.zip
debian% cd hal_142_o/linux
debian% cp -p wbusb.c wbusb.c-org
debian% vi wbusb.c
debian% diff  wbusb.c wbusb.c-org
31c31
< //                    .owner =        THIS_MODULE,
---
>                       .owner =        THIS_MODULE,
debian% cp -p common.h common.h-org
debian% vi common.h
debian% diff common.h common.h-org
16c16
< #include <linux/autoconf.h>
---
> #include <linux/config.h>
debian% cp -p Makefile.26 Makefile
debian% make clean
debian% make all
su
debian:/home/mk/src/hal_142_o/linux# cp ./w35und.ko /lib/modules/2.6.18-5-686/kernel/drivers/drivers/net/wireless/
debian:/home/mk/src/hal_142_o/linux# depmod -ae
debian:/home/mk/src/hal_142_o/linux# modprobe w35und
debian:/home/mk/src/hal_142_o/linux# dmesg|tail -1
usbcore: registered new driver w35und
debian:/home/mk/src/hal_142_o/linux# ifconfig wlan
wlan0     Link encap:Ethernet  HWaddr 00:0D:F0:2D:D4:EA
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wifi-radar で設定しようとしましたが、情報が出てきません。#ちゃんと設定すればいけるのかも。
iwlist wlan0 scanning をしてみると情報が色々足りなさそうです。

debian:/home/mk/src/hal_142_o/linux# iwlist wlan0 scanning
wlan0     Scan completed :
          Cell 01 - Address: 00:14:6C:04:6F:C6
                    ESSID:off/any/hidden
                    Frequency:2.437 GHz (Channel 0)
                    Mode:Managed
                    Quality:0/100  Signal level:-54 dBm  Noise level:-256 dBm
                    Encryption key:B7
          Cell 02 - Address: 00:18:84:17:32:46
                    ESSID:off/any/hidden
                    Frequency:2.412 GHz (Channel 0)
                    Mode:Managed
                    Quality:0/100  Signal level:-59 dBm  Noise level:-256 dBm
                    Encryption key:B7
          Cell 03 - Address: 00:18:84:17:32:45
                    ESSID:off/any/hidden
                    Frequency:2.412 GHz (Channel 0)
                    Mode:Managed
                    Quality:0/100  Signal level:-61 dBm  Noise level:-256 dBm
                    Encryption key:B7
          Cell 04 - Address: 00:A0:CA:21:C4:5E
                    ESSID:off/any/hidden
                    Frequency:2.442 GHz (Channel 0)
                    Mode:Managed
                    Quality:0/100  Signal level:-82 dBm  Noise level:-256 dBm
                    Encryption key:B7

とりあえず、ap を平にして、

iwconfig wlan0 mode managed
iwconfig wlan0 ESSID off
iwconfig wlan0 enc off
dhclient wlan0

で使えるようになりました。

しかし平文じゃ恐いので、出来ればTKIP にしたいところ。#README に使い方が載っているので多分使えます.
これから試してみます。

とりあえずwep を試そうとAP の設定をweb 128bit に変更してみたんですが,その所為か別の原因かフリーズしてました.
key は受け付けない.Ctl+Alt+Del も駄目.#Fn+F4 は効いてるみたい.
マウスも駄目.
右手前のLED 右側2つが同時に点滅.
という状態.
電源ボタン長押しで電源断しました.

#電波不安定でフリーズだとすると怖いな….

  • wep128bit
    # modprobe w35und
    # iwconfig wlan0 mode managed essid "hoge-ap" key xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xx
    # dhclient wlan0
    で繋がりました.

Wifi Radar で設定して,Disconnect button 押下でフリーズ.LED は点滅しないけどほかは同じ症状です….

  • WPA-PSK/TKIP 以下のような感じで行けました。しかし、wep よりさらに刺さりやすくなった気が…。せめてOS 巻き込まずに落ちてくれればいいんですが。
    #!/bin/sh
    
    modprobe w35und
    iwpriv wlan0 set_ie WPA_PSK_TKIP
    iwpriv wlan0 set_pwd "hogefugapiyo"
    iwconfig wlan0 essid hoge-ap
    dhclient wlan0
    w3m -dump 'https://example.com/login?user=username&password=passpass'
    最後の行はweb 認証用普通は要らないでしょう。

BT

Ver,2.0+EDR Class-1 とからしい.
BT 機器を持っていないので全く利用出来ていない.携帯をW32T あたりに機種変して利用したい.後ヘッドセット.
これも内部ではUSB 接続になっている.
Defoult では起動時にoff になっているが,BIOS で設定することにより起動時よりOn にすることも可能.
Wii リモコンでも買うか? Wii リモコン購入.
WiinRemoteで結構普通に使えています.今度IRセンサ作らなきゃ.

ヤフオクでAU のBT 対応携帯W32T を購入.
ダイヤルアップ接続は,検出して,ペアリングして,接続ってするとダイヤルアップ接続設定が1つ出来た.後は,以下の通り設定するだけで使えた.

CPU

普通に使っていると直ぐCPU が100% になってしまう.あまり並列処理はしないほうが快適に使えそう.
Firefox 起動した状態で,iTunes でPodcast DL 中ずーっとCPU100% 辛
体感的にはIntel の400Mhz 位か?

メモリ

初期状態で512MB
Slot の空きは無いので増設時は1GB のものと交換になる.
しかし,CPU のが先に底をつく感じなのでとりあえずこのままで良いかな?
後,メモリの蓋が浮いている感じがする.家だけ?

保護ケース

購入時にELECOM の物を購入したのだけど,薄手のものが付属していました. これで十分かも.

OS Setup

Windows XP Hpme

とりあえず,

  • MozillaFirefox2
  • MozillaThunderbird1.7.8
  • iTunes7
  • DivX6
  • Lastfm
  • LHAUT32
  • Winzip11
  • Gaim1.5
  • Skype2.5
  • WinSCP3
  • Putty-j
  • Gimp2.2
  • colinux
  • Leeyes
  • LimeChat2.16
  • CmdSpace?
  • Nmap
  • NetworkStumbler?
  • EmEditer?
  • GTK+2.8.18
  • Ext2 IFS For Windows
  • Daemon tools
  • CmdSpace?
  • AltIME
  • Picasa2.6
  • iTunes7
  • WiinRemote?

周辺機器

  • Wii リモコン
    BT で普通に認識して,WiinRemoteでマウスの様に使えてます.
  • PQI USB 2.0 Card Reader
    GENO秋葉原にて399円にて購入.パッケージには4GBまでの対応となっていましたが,6G MicroDrive? も普通に使えます.CF スロットより数倍早いです.
  • AU 携帯W32T BT? を参照.ダイヤルアップ普通に使えました.
    ※現在W54T に機種変更.同様に利用できます.
  • AU CF型端末 W05K 利用できました.TypeII なので無理矢理差し込むか出っ張りを削る必要があります. 詳細は->W05Kで.
  • EM・ONE S01SH 普通に利用できます. BT もUSB も.

Debian でもmodem として利用できました. 詳細->EM・ONE(s01sh)

  • CF 無線LAN PLANEX GW-CF11X
    Win/Linux 共に使えない…Win はDriver 入れなおしたら使えるようになりました.
    Linux でも認識はするんですけど電力が足りないような感じのメッセージが
    ザウルスサポートステーション を見るとSL-C3000 とかはドライバで行ける様になるみたい.頑張れば行けるのかも.
    SL-C3000 でこのドライバを使ってdmesg すると,prism2_cs を呼んでます.
    Debian Etch に刺すとprism2_pccard_cor_sreset/prism2_pccard_genesis_sreset が呼ばれている。

OtherOS

※普通にgrub やlilo をinstall すると,disk2disk のrestore が利かなくなります.grub の設定すればいけるだろうと高をくくっていた私は復元出来なくなってしまいましたorz(今のgrub では認識出来ない様)
NTLDR から呼ぶようにすればこの問題は解決するはず.そして念のためmbr のbackup を取っておきましょう.そして私にcopy して下さい(lo
mbr のbackup は以下のようにすればいけるはずです.復元は逆.(多分ねー)

# dd if=/dev/hda of=mbr.img bs=512 count=1


母艦からPXE Boot でInstall しています.
他の方法としては,別マシンからネットワーク経由でインストールイメージをコピーしてインストールしたり.
USB Boot からInstall したり(手持ちのUSB メモリA-DATA のSD 兼USB メモリの1Gは,USB メモリが対応していないらしくBoot 出来なかった)
Linux ならloadlin とかも行けそうですね.

パーティションはWindows のD ドライブ(/dev/hda2)を潰して使っています.他にも後ろの方に空きエリアとして4GB 近くあったけど,多分リカバリ用イメージが格納されていると思って手を付けていません.

Linux

解像度も広い方でいけるショートカット切替えは効かない.
Wifi/SD/ボリュームボタン が利用出来ない.
Wifi は中ではUSB の様(winbond electronics corp.製?).NDIS Wrapper でいけるか?Wifi が動かないと常用が辛いし.
SD はSUSE ではsdhci ドライバが読み込まれるのだがcard を認識しない.頑張ればどうにかなるかな?
液晶側のポインティングデバイス上での左クリックが効かない.設定でどうにかなるかも.それより中ボタンがないのでエミュレートしてるのだが,うまく同時押しが出来ない設定でタイミング変えられるかな?

VineLinux4.0

PXE Boot で別マシンに-o loop でmount したiso image からhttp 経由でinstall.
さくっとInstall は終わったが,wifi を認識しない.
boot Image はDisk 中の以下の場所から手に入れた.

/images/pxeboot/vmlinuz
/images/pxeboot/initrd.img

Ubuntu6.10

PXE Boot で別マシンに-o loop でmount したiso image からhttp 経由でinstall しようとしたが,iso image とInstall Image は違うらしくうまくいかなかった.
仕方がないので,外のserver 経由でNetwork Install. 時間が掛かったが無事終了.やはりwifi 認識せず.
sound も駄目.BT は認識してるっぽい.
boot image は以下の場所から手に入れた.

ftp://ftp.riken.go.jp/Linux/ubuntu/dists/edgy/main/installer-i386/current/images/netboot/pxelinux.0

OpenSUSE10.2

CD Image からInstall したので,Disk 交換の度にumount/mount retry.1~5まで全部利用しました.DVD 版を落としておくんでした.
install 直後で何もせずにsound やBT 等認識.

boot image

/media/loop/boot/i386/loader/linux
/media/loop/boot/i386/loader/initerd

Debian sarge r5

普通に使えますが,lsusb とかしても無線は見えないよう.kernel は2.6.18-4. BT やsound は問題無さそう.

しかしそろそろetch出るんだっけな.

Debian sid(20081111)

Etch からDistupgrade してみました. VGA と内蔵wifi 意外は良好の様.sound も鳴ります.VGA はhttp://xorg.freedesktop.org/archive/individual/driver/xf86-video-amd-2.7.7.7.tar.gz を入手,Build して動作.
USB Wifi のzd1211rw もパッケージがあるのでさくっと動作.

問題点としてs2ram(そのままでは動作しないので-f option で強行)からの復帰に失敗しますorz
#Etch では使えていたのに….

追記)なんか前面のヘッドホン端子から音が出ません. ヘッドホンを刺すとPC 本体のスピーカは鳴らなくなります.しかしヘッドホン無音.
解決.
xfce4 の音量コントロールのDuplicate Front にチェック付けたら音出る様になりました.

Xorg

VESA で生活していたのですが,tkさんから情報を頂きxf86-video-amd を試してみました。
環境はDebian etch です。

http://xorg.freedesktop.org/archive/individual/driver/xf86-video-amd-2.7.7.2.tar.gz からsource を貰ってきて、展開、./configure で足りないパッケージが色々あるので導入。 make/sudo make install

/etc/X11/xorg.conf のDevice Section を以下のように書き換え。

Section "Device"
        Identifier      "Geode"
        Driver          "amd"
        BusID           "PCI:0:1:1"
        Option          "PanelGeometry" "800x480"
EndSection

Identifier も変えたので、Screen Section のDevice も併せて変更。

        Device          "Geode"

この状態で起動すると、エラーとなりました。 ログを確認すると、amd driver が見付からないと言うエラー。
install されたpath が間違っているらしい。とりあえずln してごまかしてみる。

$ ls -ltr /usr/lib/xorg/modules/drivers/|tail -4
lrwxrwxrwx 1 root root     46 2007-09-29 14:33 amd_drv.so -> /usr/local/lib/xorg/modules/drivers/amd_drv.so
lrwxrwxrwx 1 root root     46 2007-09-29 14:33 amd_drv.la -> /usr/local/lib/xorg/modules/drivers/amd_drv.la
lrwxrwxrwx 1 root root     46 2007-09-29 14:34 ztv_drv.la -> /usr/local/lib/xorg/modules/drivers/ztv_drv.la
lrwxrwxrwx 1 root root     46 2007-09-29 14:34 ztv_drv.so -> /usr/local/lib/xorg/modules/drivers/ztv_drv.so

この状態でx 起動成功。 800x480 になり、速度も向上しました。

./configure 時にprefix を変更すると良さそうです。

描画速度も上がって良いなーと思っていたら,ハイバネ復帰に失敗する様になりましたorz

/etc/init.d/gdm stop

としてx が起動していない状態だと,復帰成功.
vesa に戻しても復帰成功.
amd に変えたので復帰失敗するようになったよう.

CTL+ALT+1 とかCTL+ALT+BS ,CTL+ALT+DEL も利きません.
電源断しか無さそう.
2,3 時間放置しても変わりませんでした.

amd 使った状態で/etc/X11/xorg.conf のDevice Section にOption "NoAccel?"を追加するととりあえずハイバネできるように.しかし,NoAccel? なのでちょっといや.もっと良い解決方法があると良いのですが.
ということで,現在のDevice Section

Section "Device"
        Identifier      "Geode"
        Driver          "amd"
        BusID           "PCI:0:1:1"
        Option          "NoAccel"
        Option          "PanelGeometry" "800x480"
EndSection

電源管理

# s2ram debian でのハイバネートはs2disk で普通に行けます。電源管理でバッテリ残り5%でs2disk として普通に動作。

が、サスペンドをs2ram で実行すると、

Machine is unknown.
This machine can be identified by:
    sys_vendor   = "KOHJINSHA Co.,Ltd"
    sys_product  = "SA Series"
    sys_version  = "Rev 1.00"
    bios_version = "S18_V0.5_EC0.8 "
See http://en.opensuse.org/S2ram for details.

If you report a problem, please include the complete output above.

と言われて出来ません。 とりあえず、

# s2ram -h

から、

    -f, --force:      force suspending, even on unknown machines.

ということらしいので、

# s2ram -f

でサスペンド成功。 電源on で復帰します。

いまのところ問題無し。

W05K を使い始めましたが,W05K を利用,cardctl eject で取り外し,s2disk でハイバネ,ハイバネから復帰,この状態で普通に使える,さらにW05K を挿入,ダイヤルアップ,しばらくするとフリーズ….
pcmcia 関連のmodule を停止してからs2disk するようにすると解決するかなー.

*BSD

FreeBSD 6.2

6.2-RC1-i386-bootonly.iso をDL
PXE-Boot image を

/boot/pxeboot

にして,

/usr/sbin/in.tftpd -l -s /media/loop/boot

CD image をNFS 共有にしてpxe boot
環境の所為かboot するまで時間がかかる.
起動メニュー(Welcome to FreeBSD の画面)で,1/2 共boot 中に再起動が掛かってしまう
orz
本を読みながらやっててエラーメッセージ等は解らず.また追試します.
いまんとこここまで.

関連URL


  • 「>パッドが狭いのでデフォルトでは移動量が小さい」ですが、マウスのプロパティで好みに調整できましたよ -- 通りすがり? 2006-12-17 (日) 08:12:25
  • 比較写真,解像度,周辺機器等を追加編集しました. -- matoken? 2006-12-27 (水) 00:30:26
  • AU のBT 携帯W32T をヤフオクで落とせたので数日中にこのテストが出来ると思います. -- matoken? 2006-12-27 (水) 00:41:00
  • W32T のダイヤルアップ特に詰まるところもなくさくっと行きましたBT? のあたりを参照ください -- matoken? 2006-12-30 (土) 03:48:14
  • OtherOS?のところにmbr についての注意を追記.その他. -- matoken? 2007-01-25 (木) 17:24:27
  • いしはらというものです.OpenSUSEをいれてみたのですが,grubのデフォルトの設定がおかしいようで,"missing operating system"になってブートできませんでした.matokenさんは,すんなりブートしましたでしょうか?なお,私はDVD版(Liveでないほう)をダウンロードして試してみました -- いしはら? 2007-05-06 (日) 21:32:26
  • こんにちわいしはらさん.私は今Debian Etch にしているのですが,OpenSUSE の時は問題なくGRUB からBoot 出来ていました.GRUB には補完機能があるのでこれでboot 出来ないでしょうか?grub 補完 - Google 検索 -- matoken? 2007-05-07 (月) 00:33:46
  • なるほど,なるほど.やってみます.ありがとうございます. -- いしはら? 2007-05-08 (火) 23:04:23
  • いしはらです.おかげさまで,OpenSUSE + winXP dualbootできました!. -- いしはら? 2007-05-11 (金) 07:40:21
  • OpenSUSE installerの"expert option"に,grubをどこに置くかのチョイスがあり,デフォルトで/になっているのをMBRに変えてインストールするだけでOKでした.grubの補完機能をおしえてもらったので,手動で/usr/sbin/grub-installの構えで臨みましたがスイッチ一つで解決してしまいました..ありがとうございました. -- いしはら? 2007-05-11 (金) 07:42:49
  • おかげさんで,OpenSUSEが快調につかえています.ところで,解像度が800x600になっているのですが,これを800x480のネイティブ解像度に落とす設定がうまくできた方はいらっしゃいませんか? -- いしはら? 2007-05-12 (土) 19:37:11
  • いしはらさんおめでとうございます。インストーラを使った方が楽かもしれませんね。解像度の件ですが、私は/etc/X11/xorg.conf を手動で以下の様に利用する色数部分(以下の例ではDepth 24)のModes を利用したい解像度からに書き換えています。XP の様に切替えることは今のところ出来ていません。Debian Etch ですが、Suse もXorg でしょうから行けると思います。念のため元のファイルはバックアップしておくことをお薦めします。 -- matoken? 2007-05-13 (日) 06:00:22
            SubSection "Display"
                    Depth           24
                    Modes           "800x480" "640x480"
    #               Modes           "1024x768" "1024x600" "800x600" "800x480"  "640x480"
            EndSubSection
  • さっそくありがとうございます.Xの設定ですね.試してみます. -- いしはら? 2007-05-13 (日) 16:55:16
  • はじめまして。私も Debian Etch 入れて使ってます。解像度は上のように設定しても私のところでは 640x480 になっているようです。 -- あべ? 2007-07-16 (月) 23:59:52
  • あべさんはじめまして.うーんX の設定は上記以外いじっ覚えが無いんですがどうだったかな,帰宅したらxorg.conf 置いてみます.ところで,640x480 以外の解像度は行けましたか? -- matoken? 2007-07-17 (火) 16:34:09
  • Etch で使っているxorg.conf を置いてみました。御参考までに. -- matoken? 2007-07-18 (水) 01:54:28
  • ありがとうございます。さっそく試してみたのですが、どうもわたしのところでは 640x480 になりますね。1024x768, 800x600 は普通に使えています。 -- あべ? 2007-07-18 (水) 23:34:24
  • すいません.追試してみたら実は800x480 で動いてなかったです.以前試したとききちんと検証できていませんでした.なんかVESA じゃ無理っぽい気がして来ました.もう少し調べてみます. -- matoken? 2007-07-20 (金) 04:13:36
  • 工人舎のunsuported driver のvideo driver で行けないかなと思って一寸見てみました.以下はarchive 中のREADME.Xorg.txt からなのですが,これにも800x480 のモードは無さそうです…. -- matoken? 2007-07-20 (金) 04:29:17
            Modes          "1280x1024" "1024x768" "800x600" "640x480" "tv-ntsc" "tv-pal"
  • 残念です。自前で Modeline 書いてみます。 -- あべ? 2007-07-23 (月) 00:27:53
  • それと別件なのですが、Etch でサウンド回りはうまくいってるでしょうか?こちらではスピーカーから音を出すことはできたのですが、ヘッドフォンをつなぐと音が出ません。 -- あべ? 2007-07-23 (月) 00:34:13
  • alsamixer の duplicate という項目を有効にしたらヘッドフォンも使えました。 -- あべ? 2007-07-30 (月) 10:26:21
  • 800x480はオプション追加で表示できます。 PanelGeometry?: Specify the geometry of the attached panel ("<width>x<height>") -- tk? 2007-09-26 (水) 19:35:34
  • 800x480はオプション追加で表示できます。 PanelGeometry?: Specify the geometry of the attached panel ("<width>x<height>") -- tk? 2007-09-26 (水) 20:07:01
  • tkさん情報ありがとうございます.試してみましたがVESA じゃ無理っぽいです.やったことは,xorg.conf のDevice section の最後にOption "PanelGeometry?" "800x480" としました.後,Modes を800x480 に.この状態でx を再起動すると画面ぐちゃぐちゃ.log は以下のような感じ. -- matoken? 2007-09-27 (木) 22:53:18
    (WW) VESA(0): Option "PanelGeometry" is not used
  • xf86-video-amd を使用してください。アクセラレーションも効いてだいぶ速くなりますよ。 -- tk? 2007-09-28 (金) 04:19:22
  • xf86-video-amd 試してみました。http://xorg.freedesktop.org/archive/individual/driver/xf86-video-amd-2.7.7.2.tar.gz を持ってきてmake install。xorg.conf のdriver をvesa からamd に。この状態でx を起動すると起動失敗。log 見るとamd が見付からないというメッセージ。インストール先が違うようなのでとりあえずln を張る。起動成功。 -- 2007-09-29 (土) 15:06:54
  • 800x480 も出来たし、速度も早くなりました。Firefox のスクロールとか全然違いますね。tkさんありがとうございました。 -- matoken? 2007-09-29 (土) 15:10:49
  • xf86-video-amd でs2disk するとハイバネーション復帰時に失敗するようです。とりあえず、Option "NoAccel?"とするとハイバネーションに成功するようになりました。 -- matoken? 2007-09-30 (日) 18:18:41
  • 無線LANは、http://www.slacky.eu/forum/viewtopic.php?p=160507&sid=f8e7d16e251fb905182fa1bcd69f43ee に黙って従ったら認識され、使える様になりました。でも、今のところ、iwconfig wlan0 xxxxx でessid等々を記述したシェルスクリプトを流さないとつないでもらえません。 -- marky? 2007-10-02 (火) 09:30:01
  • markyさん素晴らしいです。とりあえず平通信でiwconfig hogehoge としてdhclient wlan0 で繋がりました。これから暗号通信を試してみます。iwlist wlan0 scanning とかしても情報が抜け抜けです。wifi-radar とかが使えないのはその所為っぽいですね。 -- matoken? 2007-10-02 (火) 22:43:31
  • Linux on Kohjinsha SA1 - Kohjinsha SA1F00 Users | Google グループ alsa 辺りから追えてませんが役に立ちそう. -- matoken? 2007-12-11 (火) 20:15:36
  • 無線LANはここのドライバで行けました。固まりません。http://code.google.com/p/winbondport/ -- IKeJI? 2008-12-27 (土) 20:02:33
  • ディスプレードライバはDebian lennyには統合されているようです。http://packages.debian.org/lenny/xserver-xorg-video-geode -- IKeJI? 2008-12-27 (土) 20:04:22
  • IKeJIさん素晴らしい情報ありがとうございます。私も試してみます! -- matoken? 2009-01-03 (土) 01:41:27
  • 以下の様にしてDebian sid で使えました。今のところ刺さってません♪ -- matoken? 2009-01-03 (土) 19:46:33
    $ wget http://winbondport.googlecode.com/files/winbondport-030408-trunk.tgz
    $ cd trunk/linux
    $ make
    $ sudo make install
    $ sudo depmod -ae
    $ sudo modprobe w35und
    $ dmesg|tail
    [  220.780677] 0.0: ttyS1 at I/O 0x2f8 (irq = 3) is a XScale
    [  220.780991] 0.0: ttyS0 at I/O 0x300 (irq = 3) is a XScale
    [  252.012082] PPP generic driver version 2.4.2
    [  258.344030] PPP BSD Compression module registered
    [  258.883053] PPP Deflate Compression module registered
    [ 1263.265768] sizeof ADAPTER = 59164
    [ 1263.265788] [w35und]driver init
    [ 1263.265843] [w35und]wb35_probe ->
    [ 1264.408120] [w35und] _probe OK
    [ 1264.408209] usbcore: registered new interface driver w35und
    $ /sbin/ifconfig
    $ /sbin/iwlist wlan0 scanning
    $ sudo /sbin/iwconfig wlan0 mode managed
    $ sudo /sbin/iwconfig wlan0 ESSID "fon" key "xxxxxxxxxx"
    $ sudo /sbin/dhclient wlan0
  • VGA の方もsid でうまく行きました♪ http://d.hatena.ne.jp/matoken/20090104/1231045943 -- matoken? 2009-01-04 (日) 14:17:09
  • これで全部のデバイス認識ですかね.素晴らしい! -- matoken? 2009-01-04 (日) 14:22:37

spam 避けですcheck を付けて下さい

添付ファイル: filexorg.conf 1026件 [詳細] fileIMGP8533.JPG 1623件 [詳細] fileIMGP8532.JPG 1665件 [詳細] fileIMGP8531.JPG 2142件 [詳細] fileIMGP8340.JPG 1528件 [詳細] fileIMGP8337.JPG 1548件 [詳細] fileIMGP8358b.JPG 1619件 [詳細] fileIMGP8358.JPG 891件 [詳細] fileIMGP8357.JPG 1361件 [詳細] fileIMGP8334.JPG 986件 [詳細] fileIMGP8330.JPG 1002件 [詳細] filelsusb_-vv.txt 1895件 [詳細] filelspci_-vv.txt 1635件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-01-04 (日) 14:22:37 (3578d)